29 Haz 2022 18:15 Yeni Konu Oluştur

Haberler:

Sitemiz Smf 2.1 ve Smf 2.0 sürümleri için Destek ve Tema paylaşım forumudur


Kullanıcıdan bahsederken öneri yapmıyor

Başlatan Sessiz, 23 Nis 2022 14:31

« önceki - sonraki »

0 Üyeler ve 1 Ziyaretçi konuyu incelemekte.

*

  1. 31

  2. 9

  3. 1

Merhaba, kullanıcı etiketleme sistemi aktif, ancak etiketlemeye çalışınca isim önermiyor. Yani şu şekil olmuyor https://prnt.sc/-oh-_Wrgh-mm , nasıl bu şekilde olmasını sağlarım?

*

  1. 3,263

  2. 596

  3. 1076
kurduğunuz bir moddan etkileniyor olabilir

*

  1. 31

  2. 9

  3. 1
Alıntı yapılan: snrj - 23 Nis 2022 16:22kurduğunuz bir moddan etkileniyor olabilir
hocam şöyle bir sorun var; yüklediğim eklentiler paket yöneticisi kısmından gidiyor, ama işlevleri devam ediyor bu nasıl oluyor? Yani yüklü olan bi eklenti paket yöneticisinde gözükmüyor.

*

  1. 3,263

  2. 596

  3. 1076

modu kaldırmadan sil yapıyorsanız mod çalışmaya devam edecektir veya
mod kaldırırken düzgün kaldırılacak şekilde yapılandırılmamıştır kod parçacıkları kalıyordur
modu inceleyerek yaptığı değişiklikleri elle kaldırmanız gerek

*

  1. 31

  2. 9

  3. 1
Kaldırmadan bahsetmiyorum, mod zaten yüklü ama paket yöneticisinde gözükmüyor.

*

  1. 31

  2. 9

  3. 1
Kontrol ettim, ancak eklentilerle bir alakası yok.

*

  1. 3,263

  2. 596

  3. 1076
sitenize baktım konsolda xml hatası veriyor
XML ayrıştırma hatası: XML veya metin bildirimi varlığın başlangıcında değil
Konum: https://forum.seasermedia.net/index.php?action=suggest;fe95bc6edaad=c1638b94724a342d1b8ea012b73a755a;xml&search=yu&suggest_type=member
Satır: 1, Sütun: 6:

Sources/Subs-Editor.php de
alttaki function ile aynımı kontrol edin
function AutoSuggestHandler($checkRegistered = null)
{
global $smcFunc, $context;

// These are all registered types.
$searchTypes = array(
'member' => 'Member',
'membergroups' => 'MemberGroups',
'versions' => 'SMFVersions',
);

call_integration_hook('integrate_autosuggest', array(&$searchTypes));

// If we're just checking the callback function is registered return true or false.
if ($checkRegistered != null)
return isset($searchTypes[$checkRegistered]) && function_exists('AutoSuggest_Search_' . $checkRegistered);

checkSession('get');
loadTemplate('Xml');

// Any parameters?
$context['search_param'] = isset($_REQUEST['search_param']) ? $smcFunc['json_decode'](base64_decode($_REQUEST['search_param']), true) : array();

if (isset($_REQUEST['suggest_type'], $_REQUEST['search']) && isset($searchTypes[$_REQUEST['suggest_type']]))
{
$function = 'AutoSuggest_Search_' . $searchTypes[$_REQUEST['suggest_type']];
$context['sub_template'] = 'generic_xml';
$context['xml_data'] = $function();
}
}

çekim yapmkta sorun oluyor sanırım host kaynaklı olabilir hostunuzda mod security kapatmayı deneyin bi

*

  1. 31

  2. 9

  3. 1

Alıntı yapılan: snrj - 27 Nis 2022 22:04sitenize baktım konsolda xml hatası veriyor
XML ayrıştırma hatası: XML veya metin bildirimi varlığın başlangıcında değil
Konum: https://forum.seasermedia.net/index.php?action=suggest;fe95bc6edaad=c1638b94724a342d1b8ea012b73a755a;xml&search=yu&suggest_type=member
Satır: 1, Sütun: 6:

Sources/Subs-Editor.php de
alttaki function ile aynımı kontrol edin
function AutoSuggestHandler($checkRegistered = null)
{
global $smcFunc, $context;

// These are all registered types.
$searchTypes = array(
'member' => 'Member',
'membergroups' => 'MemberGroups',
'versions' => 'SMFVersions',
);

call_integration_hook('integrate_autosuggest', array(&$searchTypes));

// If we're just checking the callback function is registered return true or false.
if ($checkRegistered != null)
return isset($searchTypes[$checkRegistered]) && function_exists('AutoSuggest_Search_' . $checkRegistered);

checkSession('get');
loadTemplate('Xml');

// Any parameters?
$context['search_param'] = isset($_REQUEST['search_param']) ? $smcFunc['json_decode'](base64_decode($_REQUEST['search_param']), true) : array();

if (isset($_REQUEST['suggest_type'], $_REQUEST['search']) && isset($searchTypes[$_REQUEST['suggest_type']]))
{
$function = 'AutoSuggest_Search_' . $searchTypes[$_REQUEST['suggest_type']];
$context['sub_template'] = 'generic_xml';
$context['xml_data'] = $function();
}
}

çekim yapmkta sorun oluyor sanırım host kaynaklı olabilir hostunuzda mod security kapatmayı deneyin bi
Kodu kontrol ettim, aynı. Mod security'i kapattım, ancak sorun yine de düzelmedi.

*

  1. 3,263

  2. 596

  3. 1076
valla bilemicem detaylı incelemek lazım


Benzer Konular (1)


MENU ×