27 Şub 2021 00:10 Yeni Konu Oluştur

Haberler:

Sitemiz Smf 2.1 ve Smf 2.0 sürümleri için Destek ve Tema paylaşım forumudur


Forum Yükseltme Error! Incorrect date value: '0000-00-00' for column 'eventDate' at row 1

Başlatan Hakan KUTLUTÜRK, 12 Şub 2021 16:27

« önceki - sonraki »

0 Üye ve 2 Ziyaretçi konuyu incelemekte.

*

  1. 23

  2. 4

Forum ükseltirken
AlıntıError!
Incorrect date value: '0000-00-00' for column 'eventDate' at row 1
hatası alıyorum, ne yaptıysam bu hatayı gideremedim.

14 yıllık site, yedeği gitti,  mysql yedeğini içe aktardık, upragde çalıştırdım 2.1 rc 3, tam ilerliyor derken bu hatayı verdi, ne yapmayalıyım?

*

  1. 3,050

  2. 583

  3. 915
14 yıl önceki sürümde o sutun yok demekki doğrudan smf 2.1 geçmektense smf 2.0 geçiş yapmalıydınız
diğer konularınızda sölediğim gibi veritabanınızdaki hataları bulup elle düzenlemelisiniz
örnek olarak şu konunuzda nasıl ekleneceğini sölemiştim
https://smf.konusal.com/index.php?msg=11077

*

  1. 23

  2. 4
2.1 rc3 e yükseltmeye çalışıyorum, yükseltme çalışıyor fakat  bir yerde bahsettiğim hatayı veriyor, aynı hatayı yabancı sitelerde aradım, bir başkasıda ben gibi 1.1.21 den   2.1 rc3 e güncellemeye çalışırken forumu kaybetmiş yedek gitmiş, mysql yedeği varmış,   yazışmaları takip ettim, bazı önemli bilgileri aldım ama bir yerde birinden özel yazışmış ve yardım alıp sorunu çözmüşler. Ustam, şimdi güncelleme yaparken verilen hatayı sql sorgusunda girdiğimde şunu diyor
AlıntıSabit çözümleme:

Çözümleme sırasında 3 hata bulundu.

Değişken adı beklenmekte. (near " " at position 21)
Beklenmeyen ifade başlangıcı. (near "Incorrect" at position 0)
Tanınmayan ifade türü. (near "date" at position 10)
SQL sorgusu: Kopyala

Incorrect date value: '0000-00-00' for column 'eventDate' at row 1

MySQL çıktısı: Belgeler

#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near 'Incorrect date value: '0000-00-00' for column 'eventDate' at row 1' at line 1
Bu çözülür galiba? Çöüzülürse nasıl?

Not:   2.0  yükseltmelerini denedim çalışmadı.  2.1 rc3 ün yükseltmesi çalışıyor ama bahsettiğim hatayı veriyor

***

  1. 497

  2. 82

  3. 107

https://www.simplemachines.org/community/index.php?topic=554635.0

son mesajda cevabı verdiklerini söylemişler , işe yarar mı bilemem.
hey gidi dünya..

*

  1. 23

  2. 4

*

  1. 23

  2. 4
burda o tabloyu date formatını nasıl düzenliyordum unuttum  :DBu bölümdeki eklentileri göremezsiniz.

*

  1. 1,094

  2. 101

  3. 299
smf_members içine girin bahsedilen date kolunu düzenle diyin ve bahsedilen Varsayılan 0000-00-00 değiştirin ve düzenle diyin. Üyelerinde bu mantıkda bilgileri olmadığına dikkat edin. 

*

  1. 23

  2. 4

Bu bölümdeki eklentileri göremezsiniz. üstat  yaptım amaBu bölümdeki eklentileri göremezsiniz. gene aynı hatayı veriyor

*

  1. 23

  2. 4
ben forumu kurtaracağımıza inanıyorum, 14 yıllık forum, şimdiye kadar yardımlarınızı esirgemediğiniz için teşekkür ederim, şimdiden sonra da esirgemeyeceğiniz için minnettarım, bi gayret ustam başka ne yapa bilirim  ? :)


MENU ×