Html tagları boş gözüküyor

Başlatan cihancan, 26 Şub 2019 11:33

« önceki - sonraki »

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

cihancan

Merhaba arkadaşlar
Sitemde bir konuya html kodları eklediğim zaman konuda gözüküyor ama düzenlemek istediğimde tagların arası hiç bir kod yokmuş gibi boş gözüküyor. Bunun sebebi ve çözümü nedir?

snrj

kodu veritabanından çekerken problem yaşıyor olabilirsiniz
muhtemel sebebler kullandığınız tema etkiliyor olabilir
modlar etkiliyor olabilir
bu sorunla ilgili olabilecek dosyalar
Sources/post.php
Sources/subs-post.php

bu iki dosyanın yedeğini alıp orjinalleri ile değiştirip deneyin

cihancan

Hocam sorun hizmet aldığım host firması ile de alakalı olabilir mi? İki ayrı firmada host hizmetim var. Birisinde böyle bir sorun yok. Diğerinde bu şekilde sorunum var. Sorun firma kaynaklı ise destek birimine nereyi düzeltmesini söylemeliyim?

snrj

evet hosttan kaynaklanabilir php sürümü vs buna sebeb olabilir
hostlar bazen güvenlik tedbiri olarak bazı şeyleri kısıtlıyor

subs-post.php de şu fonksiyonu etkiliyor olabilir
Kod Seç
function htmlspecial_html__preg_callback($matches)
{
// Since we're calling htmlspecialchars we probably should know what charset we're using.
global $modSettings, $txt;
static $charset = null;
if ($charset === null)
$charset = empty($modSettings['global_character_set']) ? $txt['lang_character_set'] : $modSettings['global_character_set'];

return '[html]' . strtr(htmlspecialchars($matches[1], ENT_QUOTES, $charset), array('\\&quot;' => '&quot;', '&amp;#13;' => '<br />', '&amp;#32;' => ' ', '&amp;#91;' => '[', '&amp;#93;' => ']')) . '[/html]';
}
post.php de
Kod Seç
function strip_html_bbc__preg_callback($matches)
{
return '[html]' . preg_replace('~<br\s?/?' . '>~i', '&lt;br /&gt;<br />', $matches[1]) . '[/html]';
}

tabi başka bir yerde etkiliniyor olabilir hostunuza yazarsanız muhtemelen daha fazla yardımcı olacaklardır

cihancan

Hocam teşekkür ederim. Hosting firmasına destek bildirimi attım. Sonucu bekliyorum.