06 Ekm 2022 03:06 Yeni Konu Oluştur

Haberler:

Üye kayıt esnasında E-posta adresinizin doğru olduğuna ve Aktivasyon Mailinize bakmayı unutmayın.


SSL Kurulumu

Başlatan cihancan, 26 Mayıs 2022 09:51

« önceki - sonraki »

0 Üyeler ve 1 Ziyaretçi konuyu incelemekte.

**

  1. 50

  2. 21

  3. 17

Merhaba arkadaşlar..
Cpanel üzerinden siteme Lets Encryp SSL sertifika kurulumunu yaptım. Kurulumu yaptıktan sonra linklerin http:// şeklinde değilde https:// şeklinde güncellenmesi ve tarayıcılarda "Güvenli Değil" uyarısı vermemesi için yapmam gereken nedir diye hostuma destek mesajı attığımda şu şekilde cevap geldi.

"Sitenizde/scriptinizde sitenizin https:// olarak çalışması için gerekli ayarları yapmanız gerekebilir.

Sitenizde yeşil kilit simgesi görünmesi için, siteniz üzerinde hiçbir öğe http:// olarak çağırılmamalı, bütün öğeler https:// olarak çağırılmalıdır. Bunun için gerekli düzenlemeler siteniz/scriptiniz üzerinde yapılacağından bunu biz sağlayamamaktayız. Dilerseniz bu düzenlemeler için bir webmaster veya yazılımcı ile görüşebilirsiniz.

Bu işlemi script ayarı veya .htaccess ile yapmanız gereklidir. Scriptiniz böyle bir ayar sunmuyorsa bu .htaccess kodunu deneyebilirsiniz:"

RewriteCond %{HTTPS} !=on
RewriteCond %{REQUEST_URI} !^/\.well-known/acme-challenge/.+$
RewriteCond %{REQUEST_URI} !^/\.well-known/acme-challenge/[0-9a-zA-Z_-]+$
RewriteRule (.*) https://www.siteadresi.com/$1 [R=301,L]

Bu cevap ışığında ne gibi işlemler yapmam gerekir. Hangi dizinde bulunan .htaccess dosyasına verilen kodu girmem gerekiyor. Bu konuda yardımcı olabilir misiniz.

*

  1. 194

  2. 52

  3. 131
26 Mayıs 2022 16:21 #1 Son düzenlenme: 30 Mayıs 2022 12:03 gevv
Merhaba,


Öncelikle yedekleri alın (Veri tabanı ve Settings.php dosyası)

https://download.simplemachines.org/index.php?thanks;filename=repair_settings.php  dosyasını indirip forumun kurulu olduğu dizinde çalıştırın

örneğin; site.com/repair_settings.php

http ile başlayan linkleri https  yapıp kayıt edin  repair_settings.php
dosyasını silin.

Yönetim paneli sunucu ayarlarında Forum SSL modu / Forumda SSL`yi zorla seçip kayıt edin.  Not: bu ayar  repair settings  sayfasında da olabilir varsa değiştirirsiniz hatırlamıyorum.

.htaccess  dosyasına aşağıda ki kodu ekleyin
RewriteEngine On
RewriteCond %{HTTPS} !=on
RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

SSL yapılandırmanız doğru ise bu işlemler sonrasında  sorunsuz SSL geçişi olacaktır.



Konularda ki eski forum linklerini https yapmak için  aşağıda ki SQL sorgusunu kullanabilirsiniz. Denemedim ama büyük ihtimal sorun çıkmayacak kaynak sağlam :)

UPDATE smf_messages SET body = REPLACE(body, 'http://site.com/', 'https://site.com/');
Ben üşendim forum ayarlarında sansürlü kelimelerden düzenleme yapmıştım :D



**

  1. 50

  2. 21

  3. 17
Hocam ana dizinde .htaccess dosyası yok. Dediğiniz kodları hangi.htaccess dosyasına girmem lazım.

*

  1. 194

  2. 52

  3. 131

kendiniz oluşturun veya ekteki zip içindeki .htaccess  dosyasını atın

**

  1. 50

  2. 21

  3. 17
Hocam çok teşekkür ederim. Emeklerinize sağlık


Benzer Konular (2)


MENU ×