- “Veritabanı Hatâları Ve Çözümleri | 2.1 Beta 4 | Simple Machines Forum”

Başlatan 8Taner8, 10 Mar 2018 22:58

« önceki - sonraki »

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

8Taner8

- "Es-Selâmü Âleyküm.

 Sitemde Yeni Üye Olmak İsteyenler, Veritabanı Hatâsı Alıyor. Bu Sorunu Gidermek İçin Yardımcı Olur Musunuz? Şimdiden Teşekkürler."

snrj

as smf beta sürümünü kullanıyorsunuz hatalar olması normal birde beta 3 sürümü değil github tan beta 4 sürümünü kullandığınızda bu tür hataların olacağını ve destek almama ihtimalinizi düşünmeniz gerekir bizde bu yüzden beta sürümlerini kullanmayın diyoruz
beta 4 sürümünü ne zmn indirdiniz ve kurduysanız ozmn dan buyana github sürümünde ne tür değişikler olduysa bunları sitenize uygulayınız
https://github.com/SimpleMachines/SMF2.1/commits/release-2.1
bu hata githubta bildirilmiş veya çözülmüş mü inceleyiniz
https://github.com/SimpleMachines/SMF2.1/issues
https://github.com/SimpleMachines/SMF2.1/pulls

bu hata bildirilmemiş veya çözülmemişse github üzerinden geliştiricilere bildirebilirsiniz

bunun haricinde geliştirilmekte olan bir sürümün hatalarını gidermeye uğraşamayız
kolay gelsin iyi forumlar


CeeMoo


gevv




Alıntı yapılan: 8Taner8 - 10 Mar 2018 22:58- "Es-Selâmü Âleyküm.

   Sitemde Yeni Üye Olmak İsteyenler, Veritabanı Hatâsı Alıyor. Bu Sorunu Gidermek İçin Yardımcı Olur Musunuz? Şimdiden Teşekkürler."
Selam, @snrj   hocam   gerekli bilgileri vermiş ek olarak  öncelikle hata tam olarak nedir veri tabanı tabloları hakkındamı

bende beta 4 kurdum  her şey normal görünüyordu  yeni konu açarken veri tabanı hatası verdi "is_solved..." 
You cannot see attachments on this board.
araştırdıktan sonra  topic solved  eklentisinin oluşturuduğu bir bölümmüş  eklentiyi kaldırırken sorar verilerde temizlensin mi diye ben bunu es geçmişim  veri tabanında  kalmış  eski sürümde sorun yaratmıyordu  fakat beta 4 hata verdi  bende phpmy admin üzerinden o bölümü sildim  sorun çözüldü



8Taner8

- "Hangi Hatâ Olduğunu Göstermiyor.

Veritabanı Hatası

Lütfen tekrar deneyiniz. Eğer hata iletisini tekrar alırsanız, hatayı yöneticiye iletiniz."

gevv

Evet bir sorun var kontrol ettim  benim kurulumda farklı hata verdi

""
Bir Hata Meydana Geldi!
Bu bölüme erişme yetkiniz bulunmamaktadır.
""

githubdan bildirelim  bakalım neler olacak tahminimce sunucu kaynaklı bir durum php sürümü veya eksik bir şeyler...



Sunucunuzun  php sürümü  nedir?


Düzenleme:  Farklı bir sitede denedim sorunsuz üye olundu sanırım sunucu tabanlı bir sorun


gevv

Bildirim yaptım   farklı bir 2 yabancı sitede deneme  yaptım kayıt oldu   garip bir sorun


@snrj  hocamın @burada bahsettiği sunucu sorunu olayını şimdi daha iyi anladım :)  hatasız güncelleme olsada detaylarda  sorun çıkabiliyor.


snrj

veritabanında smf_members tablosunda eksik veya fazla modlardan kalıntı varmı bir bakın

members tablosunda olması gereken sutunlar
Kod [Seç]
 id_member
  member_name
  date_registered
  posts
  id_group
  lngfile
  last_login
  real_name
  instant_messages
  unread_messages
  new_pm
  alerts
  buddy_list
  pm_ignore_list
  pm_prefs
  mod_prefs
  passwd
  email_address
  personal_text
  birthdate date
  website_title
  website_url
  show_online
  time_format
  signature
  time_offset
  avatar
  usertitle
  member_ip
  member_ip2
  secret_question
  secret_answer
  id_theme
  is_activated
  validation_code
  id_msg_last_visit
  additional_groups
  smiley_set
  id_post_group
  total_time_logged_in
  password_salt
  ignore_boards
  warning
  passwd_flood
  pm_receive_from
  timezone
  tfa_secret
  tfa_backup

gevv

@8Taner8    hata kayıtlarına bakarmısınız  ana dizinde errorlog  dosyası   veya  sunucu yönetim panelinden

@snrj   hocam  "hide_email"  haric tüm  sütunlar beta 3 indirip kurdum onun veri tabanından bakarak sütun oluştururum dedim ama  onda da "hide_email"  sütunu  yok


snrj

ben daha eski bir install_2-1_mysql.sql bakarak yazmıştım
tamam hide_email olmucak üstteki mesajıda düzeltim
localhostta sıfır kurulumda test ettim smf 2.1 beta 3 de kayıt problemi yaşamadım
bu mesajı yazarken github sürümünü smf 2.1 beta 4 de indirip kurdum kayıt problemi yaşamadım localhostta
php sürümüm 7.1

siz upgrade yaptınız sanırım muhtemelen bir yerde birşey var ama nerde?

gevv

evet @snrj   hocam  garip bir sorun var   bende sunucu üzerinde test etmek istedim  farklı klasöre yedek aldım verittabanı kopyasınıda oluşturdum ama güncellemede  14% de kaldı  sunucu geç yanıt veriyormuş  php "max_execution_time 30" ayarı yükseltilecek  firmaya bildirdim  güncelleme sonucunu bildiririm

bu arada  sizin ingilizceniz iyi. smf ekibi ile iletişimdesiniz  her sunucuda kullanıcının php ayarlarını değiştirme yetkisi yok büyük veritabanı dönüşümünde bu sınır sorun olacak acaba bu dönüşüm işlemini forum bakımında olduğu gibi sunucuya yüklenmemek için kesintili olarak yapmak daha iyi olmazmı 

büyük veritabanı olan forumlarda ""Hataları bul ve varsa düzelt""  bakımı kesintili olarak yapılıyor sunucu kasmıyor

bunu smf ekibine bildirebilirseniz sevinirim

8Taner8

- "Sorun, Battle Motifikasyonundanmış. Motifikasyonu Kaldırınca, Veriler O Tabloda Kalıp Silinemedikleri İçin, Sorun Yaratıyormuş. Bunları Kaldırınca Da Şu Sorun Yaşanıyor:

Veritabanı Hatası

Unknown column 'mem.battle_only_buddies_shout' in 'field list'
Dosya: {Sunucu Yolu}/forum/Sources/Load.php
Satır: 1264


Bu Sorunu Nasıl Düzeltebilirim?"