Smf 2.1 Hata Kayıtları (Display.php, messageindex.php)

Başlatan medeniyetmuhendisi, 23 Şub 2018 14:14

« önceki - sonraki »

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

medeniyetmuhendisi

23 Şub 2018 14:14 Son düzenlenme: 23 Şub 2018 14:18 medeniyetmuhendisi
İyi günler forum sitemiz 2.0.15 sürümünde ancak ilerleyen zamanlarda 2.1 sürümü çıkınca şimdiden öğrenmek ve yabancı kalmamak için forum sitemizin subdomaininde smf 2.1 kurmuştuk. (celikkollu.medeniyetmuhendisleri.com)

Uzun zamandır forumda bazı ufak hatalar vardı ancak göz ardı ettim. Ama şuan daha farklı hatalar alır oldum.

Bu hataları aşağıda resimlerle anlatacağım. Hatanın neyden kaynaklandığını bilmiyorum. Yardımcı olur olursanız memnun olurum.

Display.php hatası gibi aynı şekilde messageindex.php hatasıda alıyorum onun ekran görüntüsünü hatayı verdiğinde ekleyeceğim.
Bu dosyaları orjinal halleri ile değiştirip denedim sonuç aynı değişen birşey olmadı.

bunların yanında diğer sorun ise yorumu beğendiğinde ya da iletiler ve uyarılar sekmelerine tıkladığımda resimdeki gibi bir sorunla karşılaşıyorum.







Kod [Seç]
1491: // Does the file contains any attachments? if so, change the icon.
1492: if (!empty($output['attachment']))
1493: {
1494: $output['icon'] = 'clip';
==>1495: $output['icon_url'] = $settings[$context['icon_sources'][$output['icon']]] . '/post/' . $output['icon'] . '.png';
1496: }
1497:
1498: // Are likes enable?
1499: if (!empty($modSettings['enable_likes']))
1500: $output['likes'] = array(
1501: 'count' => $message['likes'],
1502: 'you' => in_array($message['id_msg'], $context['my_likes']),
1503: 'can_like' => !$context['user']['is_guest'] && $message['id_member'] != $context['user']['id'] && !empty($context['can_like']),
1504: );

gevv

selam, güncelleme yapın  beta 4 sürümüne geçilmiş   bir çok hata düzeltmesi var.

https://github.com/SimpleMachines/SMF2.1

snrj

normalde bu tür hatalar vermemesi gerekir aldığınız hataların oluşma sebebi js dosyalarını dışardan çağırdığınız için olabilir
admin panelden özellikler ve seçenekler>genel kısımda  jQuery kütüphanesi kaynağı otomatik veya yerel olarak belirlerseniz sorununuz çözülecektir diye düşünüyorum

@gevv kardeşim github üzerindeki sürümlerde daha fazla hata ile karşılaşmak mümkün resmi siteden yayınlanan sürümler genel hataları giderilmiştir
bu arada beta4 sürümü resmi sitede yayınlanmıcak olup direk rc sürümü yayınlanacaktır
githubdan indirip kuranları görmek için resmi site github sürümünü beta4 olarak isimlendirdi
umalım ki rc1 sürümü yakında resmi sitede yayınlanır

gecitli

Biraz zor görunuyor snrj adamlar adamlar çıkarmayı birak neredeyse projeden vaz geçecekler burdaki konulara bir göz at.

gevv

Bilgiler için teşekkürler @snrj  hocam durumu anladım.


Ara sıra  atışıyorlar :)  @gecitli   hocam  benim anladığım  bir kısım gereksiz şeylerle uğraşıyoruz geç kaldık diyor diğerleride ince eleyip sık dokuyor. Bu konularda anlaşamıyorlar galiba...

Şuan 9 açık rapor var  neredeyse 15...20 günde bir tane kapatılıyor. Bir ara hepsi kapandı tamam bitti bu iş derken kısa sürede raporların hepsi açıldı...

snrj

bende işin olumlu tarafından bakmak isteyenlerdenim ama beta sürümleri 4 sene oldu yani pekte umutlu değilim
benimde anladığım kadarıyla smf geliştirici ekibi içinde smf 2.1 alpha sürümlerinden buyana bir çok sorun var takımdan ayrılanlar ve başka bir çok fikir ayrılıkları var gibi gözüküyor
Ayrılanları çoğunluğu burda sanırım https://www.elkarte.net/ smf tabanlı ayrı bir proje

rc sürümünden sonra köklü bir değişiklik yapılmıcak bildiğim kadarıyla buda mod ve tema yapımcıların işe koyulması demek
rc sürümü smf için kırılma noktası bence ya işler iyiye gidecek yada daha kötüye :D bakalım yaşayıp görecez

medeniyetmuhendisi

@snrj hocam, emin olmak adına bir iki gün hata kayıtlarını takip ettim. Sizinde belirttiğiniz düzeltmeyi yapıp tekrardan beklemeye koyuldum ama aynı hataları almaya devam ediyorum


snrj

sitenize üye olup baktım google analaystic script kodlarında veya ekleneşinde problem var
kodları elle eklediyseniz başka bir tarafa alın kodu

kodun tarayacı araçları kısmındaki görüntüsü

Kod [Seç]
<div class="overview" style="top: 0px;">
<script type="text/javascript"><!-- // --><![CDATA[
var _gaq = _gaq || [];
_gaq.push(['_setAccount', 'UA-58597928-3']);
_gaq.push(['_trackPageview']);

(function() {
var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
})();
// ]]></script>
 class="pm_bar"&gt;
<div class="pm_sending block">


medeniyetmuhendisi

27 Şub 2018 22:24 #8 Son düzenlenme: 28 Şub 2018 16:04 medeniyetmuhendisi
Hocam herhangi bir kod yerleştirmedim ben,

Google Analytics Code modu yüklü ordan sadece kimlik numaramı girmiştim o kadar. şimdi uygulamayı kaldırdım. beklemede olacağım tekrardan. duruma göre yeniden mesajımı editleyeceğim.


Edit 1 : @snrj hocam dediğiniz gibi Google Analytics Code modunu kaldırdım ve şu sorunlar düzeldi.





Ancak Hata kayıtları devam ediyor.

medeniyetmuhendisi

@snrj hocam sanırım görmediniz en son sorunlar devam ediyor ve her geçen gün artıyor herhangi bir değişiklikte yapmadım ki hiç anlamadım gitti.

http://smf.konusal.com/index.php?topic=2006.0 ; bu konuda da aslında aynı sorunlar konuşulmuş ama beta4 için konuşulmuş bu yüzden bir şeye de dokunamadım.

aydınlatma imkanınız olabilir mi acaba?

snrj

sitenizde 684 nolu konuya baktım üstte verdiğiniz koda göre eklenti kısmını inceledim dil eksikliği yüzünden hata veriyor olabilir
yönlendirdiğiniz konuda yazdığım gibi sonuç itibariyle beta sürümünde hataların olması normal bir durum
Themes\default\languages/index.turkish-utf8.php de
bul
Kod [Seç]
$txt['add_poll'] = 'Anket ekle';öncesine ekleyin
Kod [Seç]
$txt['attach_downloaded'] = 'Yükleme: %1$d';
$txt['attach_viewed'] = 'Gösterim: %1$d';

kurduğunuz modlar veya sitenizi smf 2.0 sürümünden upgrade yapmadan önce kurduğunuz modların kalıntıları olabilir
bunlarda hataya sebeb olabilir
veritabanında bu modların kalıntılarını araştırın

medeniyetmuhendisi

@snrj üstadım öncelikle Allah milyon kere razı olsun senden. Emin olmak adına bir kaç gün bekledim. Dediğiniz düzeltmeden sonra display.php hataları başta olmak üzere bir sürü hata sona erdi.

şuan aldığım tek hata messageindex.php hatası onun haricinde başka bir sorunum kalmadı gibi.

aldığım hata da şu;

snrj

hata mesajı gayet açık aslında veritabanında ilgili sutunlar yok diyor
muhtemelen bir mod kalıntısı veya düzgün kurulmamış bir moddan kaynaklı
Sources/messageindex.php ekleyin bakalım

medeniyetmuhendisi

buyrun hocam ekte. smf yi bilen biri değilim o yüzden yanlış birşey yapmak istemiyorum.

snrj

dosyayı inceledim bir hata gözükmüyor sorunun nerden kaynaklandığını çözemedim açıkcası