Smf 2.0.x Php Versiyon /?

Başlatan gencveteriner.com, 28 Ara 2017 22:01

« önceki - sonraki »

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

gencveteriner.com

merhabalar herkese kolay gelsin

Şu anda sitemde smf 2.0.15 sürümünü kullanmaktayım. Herkesin malumudur ki PHP 7 versiyonu çıktı. PHP sürümümü 7 ye çıkardığım zaman sitem çalışmıyor şu anda PHP 5.6 da anca çalışıyor.

Smf forum sitemi PHP 7 versiyonunda nasıl tam olarak aktif bir şekilde çalıştırabilir.

kolay gelsin

CeeMoo

Aslında burda olay smf bağlanma sisteminin eski olması ve php7 artık eski bağlanma mantıklarına destek vermiyor ondan hata alıyorsunuz.

 Bildiğiniz gibi smf ücretsiz olduğu için veya başka sebeblerden dolayı yavaş yavaş geçiliyor.

 Bir diğer husus ise smf geniş çaplı sistem sistemin arka çalışırın yükseltilmesi zaman alıcaktır.

2.0.15 değil de 2.1 tam gelince olucaktır.K.gelsin

gencveteriner.com

2.1 re geçeceğim ama hala beta yanlış hatırlamıyorsam 1 seneyi geçti hala beta hala beta sen sürümü ver açıklar güncelleme ile kapatılır amaçlar ne bılmıyorum mesela 1.0 dan 2.0 ra geçiş gayet makul bir zamanda oldu ama 2.1 ne diye bu kadar uzatıyorlar anlamıyorum birde dünya da birçok destek sitesi beta sürümünü kullanıyor ve denedi bu konuda bir bilginiz var mı_? ne zaman gelcek 2.1_?

snrj

smf 2.0.15 ve yeni çıkacak sürümlerin hepsi php 7 de çalışır
smf sıfır kurulumda bu hata yok
sitenizin hata vermesinin nedeni kullandığınız modlardan kaynaklıdır modların bazıları php7 de hatalara neden açabiliyor
örnek olarak şu iki konuyu okuyunuz
http://smf.konusal.com/index.php?topic=1290.msg8994#msg8994
http://smf.konusal.com/index.php?topic=1194.msg8984#msg8984

kullandığınız modların son zamanlarda güncellenip güncellenmediğini kontrol ediniz mod yapımcısına ulaşıp php 7 sürümüne göre düzenlenmesini istiyebilirisiniz
veya php bilginiz varsa modları kendinizde düzeltebilirsiniz
veya çok önemli bir mod değilse kaldırabilirsiniz
veya php sürümünü modlar güncelenesiye kadar düşük tutabilirsiniz

smf 2.1 sürümü için evet ne yazıkki gecikmeli gelen bir sürüm olacak şuana kadar çıkmış olması gerekirdi smf ekibinden ayrılanlar olması sanırım bunu tetikledi ve tamamen ücretsiz olması ve gönüllülerden oluşan bir ekip olması ve zaman ayırabildikleri süre çerçevesinden ilgilenebildikleri için smf 2.1 de çıkması zaman alıyor
şimdilik beta sürümü olduğu için geçmeniz doğru olmucaktır rc sürümü muhtemelen önümüzdeki yıl çıkacaktır tabi bu bir tahmin



gencveteriner.com

29 Ara 2017 16:41 #4 Son düzenlenme: 29 Ara 2017 16:44 gencveteriner.com
bilgi için teşekkürler sorun modlarsa ben hallederim ama admin panelinden baktığım zaman tüm modlar güncel acaba upgrade mi yapsam
teşekkürler...

snrj

herhangi bir işlem yapmadan önce yedek almanızı öneririm

gencveteriner.com

30 Ara 2017 14:43 #6 Son düzenlenme: 30 Ara 2017 14:49 gencveteriner.com
yedek alalım tabi ki de paketlerin hepsi güncel 2.0.11 den beri update ile 15 oldu. 2.0.15 e upgrade mi yapayım ya da tema değişimi yapıp modları da yeniden mi yüklüyeyim ya da modları php7 sürümüne uyumlu hale getirin dediniz bunu nasıl yapabilirz bana net bir yol göstermeniz mümkün mü? teşekkürler..

snrj

kullandığınız modlar güncellenesiye kadar bekleyin php 5.6 kullanmanızda bir sakınca yok

gencveteriner.com

benim wordpress tabanlı kullandığım vetrehberi.com diye farklı bir sitem daha var aslında hostumda 3 wp 1 smf var wp nin daha hızlı olması için php7 ye geçmem gerekiyor

bundan dolayı smf nin de php 7 de çalışır hala getirmem lazım. tema değiştirmeyi de düşünüyorum sizin temalardan foro temasını çok beğendim ama ücretli olduğu için maalesef olmuyacak ama ücretsiz olanlardan dokuzharf olabilir.

Yani kısacası tema değişmesi gerekiyorsa onu da yapacam modlar admin panelinden bakıldığında hepsi yeşil ışık yani günceller ya modları kaldıracam, ya tema değişecem, ya upgrade yapacam yani ne yapmam gerekiyorsa bana yapmam gereken konusunda yol haritası söylerseniz onu izliyeceğim.

cevap için teşekkürler.

snrj

illa geçecem diyorsanız yedek alın sonra modlları kaldırın sonra php7 ye geçiniz sonra temanızı kurun sonra modları tek tek kurup hangisi hata veriyorsa bulmanız lazım vs.. bunun haricinde söyleyebileceğimiz bir şey yok ne yazıkki

gencveteriner.com