Smf Yeni sürümlere güncelleme (upgrade) nasıl yapılır?

Başlatan snrj, 17 May 2014 08:35

« önceki - sonraki »

0 Üye ve 4 Ziyaretçi konuyu incelemekte.

snrj

Yönetici Panelinden Yükseltme
Güvenlik güncellemeleri ve diğer ufak güncellemer yönetici panelin'in Paketler bölümünden otomatik olarak indirilip kurulabilmektedirler. Bu tür güncellemeleri bu şekilde yapmanız tavsiye edilir (mesela 1.1.3'ten 1.1.4'e).

Notlar:
  • Yönetici panelinden upgrade işlemi genelde modifikasyon ve diğer değişikliklere zarar vermez.


Upgrade Paketi ile Yükseltme
Bu yöntem ile herhangi bir SMF veya YaBB SE sürümden son SMF sürümüne geçiş yapabilirsiniz. Lütfen "X sürümünden, Y sürümüne geçiş yapılabilir mi?" diye sormayın. Cevabı evettir.
1) Downloads bölümünden yükseltme yapmak istediğiniz sürüme ait upgrade paketini indirin. Dikkat edin, update değil, upgrade. Mesela forum sürümünü 1.0.5'ten 1.1 RC1'e güncellemek istiyorsunuz. Örnek dosya adımız budur: smf_1-1-rc1_upgrade.zip
2) Daha sonra dil dosyaları bölümünden güncelleme yapmak istediğiniz sürüme ait Türkçe dil dosyalarını indirin. (Forumu Türkçe kullanıyorsanız tabi) Örneğimizdeki dosya adı: smf_1-1-rc1_turkish.zip
Şimdi elimizde iki adet paket var. Bunları dilersek bilgisayarımızda paketten çıkarabilir, dilersek de (cPanel'i olanlar için) sitemize yükleyip doğrudan sunucu üzerinde paketten çıkarabiliriz.
Şimdi en basiti olan birinicisini yapalım. Bu iki paketin içindekileri Winzip veya benzeri yardımıyla bilgisayarımıza çıkartıyoruz. Sonra aynen olduğu gibi sitemize yüklüyoruz. (FTP veya benzeri ile)
Eski dosyaların üzerine yazıyoruz.
3) Son olarak upgrade.php isimli dosyayı çalıştırıyoruz. Ör:
Kod [Seç]
http://www.site.com/forum/upgrade.phpBunu açınca bir tane düğme çıkacak. Ona basın yeter :)
Yeni sürümünüz hayırlı olsun. upgrade.php dosyasını silmeyi unutmayın.

Notlar:
  • Güncelleme işlemi ileriye doğru olur. 1.1.x sürümlerinden 1.0.x sürümünlerine veya 2.0 sürümlerinden 1.1 sürümlerine geri dönemezsiniz!
  • Bu işlemle kessinlikle forumununzdaki mesajlar, konular, bölümler, vs. silinmez, kaybolmaz.
  • Kurulu modifikasyonlar çalışmaz, modifikasyonların konularını okumanız ve güncelleme işlemi öncesinde bütün modifikasyonlarınızı kaldırmanız tavsiye edilir. Upgrade işleminden sonra tekrar kurabilirsiniz.
  • Kurulu temalar için de aynı şey geçerlidir.
  • Önemli güvenlik güncellemeleri (mesela 1.1'den 1.1.1'e veya 1.1.1'den 1.1.2'ye) modifikasyon paketi olarak da yüklenebilir. Paketler sayfasındaki uyarıyı izleyin.

KaPTaN6

03 Tem 2017 11:27 #1 Son düzenlenme: 03 Tem 2017 11:29 KaPTaN6 Sebep: Resim eklenmedi
Merhaba bu işlem esnasinda soyle bir hata aldim bu konuda yardimci olurmusunuz.


Executing database changes
Please be patient - this may take some time on large forums. The time elapsed increments from the server to show progress is being made!
Executing: "Changing column names." (1 of 42)

!!Error!
You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near 'binary' at line 11



hosting saglayicimdan destek istediginde yazilimla alakali bir sorun bu konuda yazilim destegi almalisin diye bir cevap aldim.

CeeMoo

@KaPTaN6 MariaDB server version Smf şurda sistem gereksinimlerini yazıyor :   --- https://download.simplemachines.org/requirements.php

KaPTaN6


CeeMoo

@KaPTaN6  db olarak altdaki sistemlere uyum sağlıyor.

One of the following databases must be installed:

    MySQL 4.0.18 or higher (at least 4.1.0 would be better) and PHP MySQL client API 4.0.18 or higher.
    PostgreSQL 8.0 or higher (standard_conforming_strings must be set to off, starting from PostgreSQL 9.1 default is on)
    SQLite SQLite 2.x (SMF is not compatible with SQLite 3.x)

KaPTaN6

Alıntı yapılan: CeeMoo - 04 Tem 2017 12:43@KaPTaN6  db olarak altdaki sistemlere uyum sağlıyor.

One of the following databases must be installed:

    MySQL 4.0.18 or higher (at least 4.1.0 would be better) and PHP MySQL client API 4.0.18 or higher.
    PostgreSQL 8.0 or higher (standard_conforming_strings must be set to off, starting from PostgreSQL 9.1 default is on)
    SQLite SQLite 2.x (SMF is not compatible with SQLite 3.x)

site zaten smf kurulu 1.1.21 den 2.014 e gecerken aliyorum hatayi

CeeMoo

@KaPTaN6 sunucu sağlıyıcınıza verdiğim link atarsanız daha kapsamlı cevap alabilirsiniz.

KaPTaN6

kontrol ettik bir sorun gözükmemekte php versiyon 5,5 te onlarda sorunun sql den oldugu söylüyorlar sql de sorgu calistirdigimda
Hata
Sabit çözümleme:

Çözümleme sırasında 5 hata bulundu.

Varlığın adı beklenmekte. (near "alter" at position 13)
Açık bir köşeli parantez beklenmekte. (near "alter" at position 13)
En az bir sütun tanımı beklenmekte. (near " " at position 12)
Beklenmedik ifade başlangıcı. (near "first_day" at position 20)
Tanınmayan ifade türü. (near "DATE" at position 30)
SQL sorgusu:

CREATE TABLE alter (first_day DATE, last_day DATE)

MySQL çıktısı: Belgeler

#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near 'alter (first_day DATE, last_day DATE)' at line 1


şu sekilde hata aliyorum bu konuda bilginiz var mı.

CeeMoo

@KaPTaN6  kardeş bu Db sistemleri ile ilgili bilgim olmadığı için hosting yazarsanız daha iyi sonuç alırsınız dedim.Bilsem gerçekten direk cevabı yazarım konuyu bu kadar uzatmam.Anlayışın için Teşekkürler

dokuzharf

aynı domaine bi klasör oluşturarak 2.0.14 sürümü kur, sorunsuz kuruluyorsa çözümü bulmak için yeniden konuşalım.
hey gidi dünya..

KaPTaN6

Alıntı yapılan: CeeMoo - 06 Tem 2017 15:50@KaPTaN6  kardeş bu Db sistemleri ile ilgili bilgim olmadığı için hosting yazarsanız daha iyi sonuç alırsınız dedim.Bilsem gerçekten direk cevabı yazarım konuyu bu kadar uzatmam.Anlayışın için Teşekkürler
Tesekkür ederim ilgin icin.

Alıntı yapılan: mavice - 06 Tem 2017 20:58aynı domaine bi klasör oluşturarak 2.0.14 sürümü kur, sorunsuz kuruluyorsa çözümü bulmak için yeniden konuşalım.
kurulumu yaptım su anda sorunsuz kuruluyor. sanirim hosting firmasinin dedigi gibi sql le ilgili bir sorun var